fbpixel

No puedo pegar un post en Facebook

Una cliente está tratando de compartir un post en facebook y no pasa nada.

Puse la url en Facebook debug y me dice:

No podemos revisar este sitio web porque el contenido no cumple nuestras Normas comunitarias. Si crees que se trata de un error, avísanos.

Probé con otros artículos y todos me dicen lo mismo.

A alguien le pasó?

Tengo una sospecha con respecto a este tema, en la web tienen links para bajar el software. (3 exe, un zip y un msi)

Tendrá algo que ver?

gracias!!

Continúo con esta “autoterapia” de grupo (solo…)

Bueno, he seguido indagando y este problema surge luego de haber sufrido un hackeo el año pasado.
Dicho hackeo no se que onda, pero lo limpié como pude y se ve que mal.

Por un lado hice una revisión con https://mxtoolbox.com/ y aparece en una blacklist…

Por otro lado, mi cliente me pidió que le agregue los links a las redes sociales. Al agregar los links, quise hacer un ajuste en los CSS usando el Personalizador y no me dejaba publicar los cambios…

¡revisando, voy al final del CSS y me encuentro con un script!!! dentro del CSS!!

Lo copié y lo guardé en un documento y luego lo borré.

Ahora, ¿cómo puedo revisar y sanear todo el sitio?

¿Alguna idea, alguien da este servicio?

gracias!!!

En una Meetup, Marcelo Pedra dio una charla para limpiar sitios infectados. Luego subió la presentación a los comentarios de dicho Meetup. Una de las herramientas que recuerdo era Sucuri

1 me gusta

Hola Miguel, tiene algún firewall instalado el sitio?
Podés hacer un chequeo con alguna de estas herramientas a ver si te da algún dato:
https://sitecheck.sucuri.net/
https://www.virustotal.com/gui/home/url
Lo recomendable es que te bajes una copia del sitio y revises a fondo en entorno local. Al bajarte un zip por ejemplo y descomprimirlo en tu equipo, ya tu sistema operativo puede detectar algún archivo sospechoso.
Son algunos tips. Espero te sirvan.
Saludos!

2 Me gusta

despues del hackeo lo pase por sitecheck.sucuri.net y le pasé varias de estos malware plugins, etc. (medio desesperado, error) y no documenté bien…
En su momento encontré un script, lo busqué y lo borré.

Luego instalé WordFence para que no entrara nada más.

Pero evidentemente quedó algo en algún lado, porque al intentar agregar un CSS en el Personalizador, apareció ese script…

Si bien puedo intentar buscar y pasarle algunas herramientas, prefiero que lo haga alguien que sepa lo que está haciendo.

Gracias @Gustavo!!

PD: lo pase por ambos sitio que me pasaste y dio todo ok.

Como andan. Che esto me hace ruido: ¿que links tienen en donde y para bajar que software??

1 me gusta

Pasale el scanner del Wordfence en modo Sensitive, así analiza las imágenes, porque muchos virus se “disfrazan” de jpg para que los pases por alto.

Si en mxtoolbox sale que está en una blacklist, tenés que 1) probar la IP del hosting a ver si aparece en blacklist y comparar, a lo mejor está listado el dominio nomás, y 2) seguir el link que te dan en mxtoolbox para pedir el desbloqueo.

También agregá si no lo hiciste todavía, el dominio a Google Search Console así ves si ellos detectan algo también.

En el hosting fijate 1) que no hayan configurado un cronjob que llame al php del virus, 2) si es cPanel: fijate que no hayan cambiado el email de contacto en Preferencias, y fijate en el archivo /.lastlogin a ver si hay logins desde IPs que no sean tuya o del cliente. Podés chequear de donde es una IP sospechosa usando https://www.ultratools.com/tools/geoIpResult

2 Me gusta

Wow esta es la respuesta de alguien que sabe.

Marcelo, muchas gracias!!!

Me faltó agregar…

  • Cambien la contraseña del panel de control y FTP.
  • Cambien la contraseña de los usuarios del WordPress.
  • Fijarse si no hay usuarios que no deban estar.
  • Si hay usuarios admins que no usen el sitio, pero que no se sabe si pueden estar comprometidos, es mejor ponerles rol de suscriptor y cuando necesiten entrar pasarlos de nuevo a admin. Y obvio también cambiarles las claves!

Por lo del CSS que no te deja guardar, tenés que fijarte si sale algun mensaje de error en la Consola del navegador cuando abrís distintas páginas.
También probá a guardar el CSS en el Personalizador teniendo primero todos los plugins apagados. Si ahí te permite, entonces tenés algo a bordo de algún plugin, que puede ser virus o puede ser incompatibilidad. Si tampoco te permite, entonces o tenés algo en el theme, o está infectada la instalacion de WP.

Tenés que fijarte a ver si no hay código extraño en el .htaccess, index.php, wp-config.php y dentro del functions.php del/los theme/s…

Después contá que encontraste… :smiley:

1 me gusta

Gracias @marcelo.ampm!!!
estoy haciendo paso a paso todo lo que dijiste.

Ya les contaré!

1 me gusta