fbpixel

Error de actualización WordPress

Hola, como están? estoy con un problema. Accedí a un wordpress, actualice las versiones y me surgió este error

**Warning** : ftp_nlist() expects parameter 1 to be resource, null given in  **/home/izel/webapps/infogestion_web/wp-admin/includes/class-wp-filesystem-ftpext.php**  on line  **402**

**Warning** : ftp_pwd() expects parameter 1 to be resource, null given in  **/home/izel/webapps/infogestion_web/wp-admin/includes/class-wp-filesystem-ftpext.php**  on line  **226**

**Warning** : ftp_pwd() expects parameter 1 to be resource, null given in  **/home/izel/webapps/infogestion_web/wp-admin/includes/class-wp-filesystem-ftpext.php**  on line  **226**

**Warning** : ftp_pwd() expects parameter 1 to be resource, null given in  **/home/izel/webapps/infogestion_web/wp-admin/includes/class-wp-filesystem-ftpext.php**  on line  **681**

**Warning** : ftp_nlist() expects parameter 1 to be resource, null given in  **/home/izel/webapps/infogestion_web/wp-admin/includes/class-wp-filesystem-ftpext.php**  on line  **402**

**Warning** : ftp_pwd() expects parameter 1 to be resource, null given in  **/home/izel/webapps/infogestion_web/wp-admin/includes/class-wp-filesystem-ftpext.php**  on line  **226**

**Warning** : ftp_pwd() expects parameter 1 to be resource, null given in  **/home/izel/webapps/infogestion_web/wp-admin/includes/class-wp-filesystem-ftpext.php**  on line  **226**

**Warning** : ftp_pwd() expects parameter 1 to be resource, null given in  **/home/izel/webapps/infogestion_web/wp-admin/includes/class-wp-filesystem-ftpext.php**  on line  **681**

**Warning** : Cannot modify header information - headers already sent by (output started at /home/izel/webapps/infogestion_web/wp-admin/includes/class-wp-filesystem-ftpext.php:402) in  **/home/izel/webapps/infogestion_web/wp-includes/pluggable.php**  on line  **1265**

**Warning** : Cannot modify header information - headers already sent by (output started at /home/izel/webapps/infogestion_web/wp-admin/includes/class-wp-filesystem-ftpext.php:402) in  **/home/izel/webapps/infogestion_web/wp-includes/pluggable.php**  on line  **1268**

Aparece en la parte superior de todas las paginas de la web y no me permite entrar al panel. Busqué como solucionarlo, en este blog vi que recomendaron borrar la carpeta admin e includes pero no funciono, también me salió esta solución https://wordpress.org/support/topic/ftp_nlist-warnings/ pero dentro de los archivos no encontre el wp_filesystem del que habla el usuario que lo soluciono. Alguien sabe que puedo hacer?

Hola.
Intenta entrar por FTP y copiar todos los archivos de WP a mano.

Si tenes SFTP o SSH mejor pues tenes que subir el zip y ahi dentro descomprimirlo.

PD: Recuerda antes de actualizar algo siempre debes tener backup de la web y de tu DB
Saludos

2 Me gusta

Constanza, como estás?

Por lo que entiendo, al final el wp-config.php, tenes que agregar lo siguiente:

if ( ! defined( 'FS_METHOD' ) ) define( 'FS_METHOD', 'direct' );

Avisanos si te funciona.

Saludos,
Diego

1 me gusta

Otra alternativa es subir el .zip desde el File Manager del CPanel y ahí descomprimirlo en la carpeta del wp-content/themes.

También recomendaría ver qué versión de PHP está usando el servidor. Debería ser 7.3 para arriba.

1 me gusta

Muchas gracias por la ayuda! Al final opte por pedir al hosting que vuelvan a una versión anterior. Se trata de un sitio que no realice yo y tiene fallas por todas partes :roll_eyes: