fbpixel

Error 404 con pagina que no es la portada

Buenas tardes gente, como va?

Tengo una consulta que no puedo resolver, tengo mi dominio:

http://104.154.143.186/webtest/wordpress/

que la pagina de inicio se ve bien, ahora el problema esta cuando creo una pagina nueva ejemplo:

http://104.154.143.186/webtest/wordpress/casos-de-exito

cuando quiero visualizar una pagina que no sea la portada, me arroja error 404 not found.

Los enlaces permanentes los tengo como “nombre de entrada”, pero nose a que se debe este error, a alguien le paso alguna vez?

Gracias

Hola, probá lo siguiente:

  1. En el backend de WP, andá a “ajustes” -> “enlaces permanentes” -> “Ajustes comunes”

  2. Ahí modificá la configuración (te recomiendo que eljas la picón “simple”). NO OLVIDES GUARDAR.

  3. Luego intentá acceder al sitio con la url con la estructura simple, en su caso sería algo así:
    http://104.154.143.186/webtest/wordpress/?p=xxx (donde xxx sería el númer id de tu página).

  4. Si funciona, volvé a la configuración enlaces permanentes, en el backend de WP, andá a “ajustes” -> “enlaces permanentes” -> “Ajustes comunes”

  5. Volvé a configurarlo como estaba anteriormente y GUARDALO.

Después de esto debería funcionar bien, es algo tipico que ocurre en WP.

Podrías saltear el paso 3, pero yo lo haría a ver que aparece.

Espero que con esto se solucione el tema.
Saludos.

Buena! Ahi probe cuando lo pongo como simple funciona correctamente, ahora lo vuelvo a nombre y deja de funcionar… sabes que puede ser?

mmmmm… no estoy seguro, es un error típico de wordpress que cachea algo de eso. Con lo que te dije yo siempre lo solucioné.
No estoy seguro si es posible esto, ¿pero puede que tenas dos páginas distintas con el mismo slug?. Por ejemplo dós páginas que en su URL apunten a:
http://104.154.143.186/webtest/wordpress/casos-de-exito

O corroborá que el slug de la página wordpress lo tenga registrado igual acomo lo escribis vos en el navegador, por lo que vií no se puede llegar a esa página mediante un link, hay que ingresar a mano la URL. Puede que no exista una págian con ese slug (casos-de-exito)

Espero te sirva.

Veo que tenés dentro del menú 2 veces “Casos de Éxito”, si es la misma páginas, debería andar bien, ahora si tenés generadas 2 págias puede que ahí esté el problema.

Buenas! Las del menu no eran paginas, sino un enlace personalizado que habia hecho para maquetar la idea de las paginas.

Las paginas me siguen sin levantar, que es lo raro.
Monte todo esto mismo en mi servidor y levanta las paginas con sus enlaces lo mas bien.

Nose bien que puede ser, que raro.

Extraño, seguí probando cambiar la configuración de los enlaces permanentes. Probá una a una todas las o opciones y volvé a la que quieres tener configurada.
Eso es lo que yo haría.
Saludos.

si es lo que probe pero nada, solamente funciona la simple con el id de la pagina, raro.

Vere que onda

Y? lo pudiste resolver? que era? Me quedó la curiosidad

1 me gusta