fbpixel

Actualizar a PHP8 y WP 5.6

Buenas, cómo están?

Soy medio fan de mantener todo actualizado, especialmente si hay ventajas de performance, pero ir a la par de lo último tiene su precio en riesgo… por eso quería consultar si tenían opiniones/experiencia con PHP 8 y WP 5.6.

Muchas gracias!

Como te va Gonzalo. PHP 8 todavía no está full full aceptado por muchos plugins y themes, y si bien trae muchas mejoras de rendimiento, todavía incluso WP declara que no está 100% testeado en el core. Incluso a nivel hosting si bien cPanel lo empezo a distribuir, hay aplicaciones que todavía no se actualizaron.

Yo por ejemplo lo voy a desplegar en los servidores acá en el hosting recién a fines de enero como para dar tiempo a que se actualicen y maduren, no solo los plugins, sino PHP mismo también, porque todos los meses saca 1-2 updates con correcciones… Así que lo recomendable es mantenerse todavía en 7.4 si tenés todo actualizado a versiones de WP+plugins+theme que sean del 2020.
Y sino, lanzate a la pileta y contanos si anda bien con PHP 8. La experiencia dice que si te funciona bien con 7.4, debería andar bien con la 8, aunque como decía Tu-Sam: “puede fallar”…

Saludos!

2 Me gusta

Muchas gracias por la respuesta @marcelo.ampm!

Exactamente eso me pasa. A WP 5.6 ya me subí. En algunos sitios encontré algunos issues con Woocommerce:

[18-Dec-2020 18:34:21 UTC] The WC_Cart::get_item_data function is deprecated since version 3.3. Replace with wc_get_formatted_cart_item_data.

Pero no mucho más. Como tengo solo un sitio en SiteGround, donde tienen Php8, por ahí pruebo y les cuento. Cualquier cosa vuelvo para atrás (como si no tuviese nada que hacer).

Saludos!

Sí, lo bueno es que es reversible.
Ese error de PHP que mostrás me suena más a una incompatibilidad de algún plugin de WooCommerce por usar la API vieja en vez de algo relacionado con versión de PHP.

Saludos